Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Normal
    • Resolution: Incomplete
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Attachments

        Activity

        drobbins Daniel Robbins added a comment -

        Whenjobs is a very interesting project and I am interested in having people test it out and evaluate it and tell Martin and me what you think about it.

        jamiel Jamie Learmonth added a comment -

        I've only had a quick read of the man page but it seems to be lacking a few features like "every day at 14:00" or "every monday at 3pm", or am I missing something?

        golodhrim Martin Scholz added a comment - - edited

        Jamie Learmonth that's what we want to figure out in testings, and why we asked for stuff like that, but a try of it should bring in clearing... The problem is that whenjobs is atm a very young project and perhaps we can improve it ourself or do it with help of Richard Jones from Red Hat, to get better support for us and him with whenjobs. as already added we have improved it with two own works in it... and we see what he says about them upstream later...

        golodhrim Martin Scholz added a comment - - edited

        Jamie Learmonth the solution for that is pretty simple if you play a bit with whenjobs and console scripts:

        so here is how to get it work.

        1. Add a minute running script:
            every 1 minute :
                <<
                testtime=`date +%H%M`
                whenjobs --set --type int test=${testtime}
                >>
            
        2. Add a when clause:
            when test == 0017 :
                <<
                echo `date` >\> ~/test.log 
                >>
            

        so the first job generates every minute a variable called testtime in the form of HHMM (HH=Hour(24h mode),MM=Minute) and sets this testime to a whenjobs-variable called test, finally our when clause checks for that test-whenjobs-variable and calles the code for it if test equals 0017 in the above case. so it runs every day at 00:17... playing with it brings the solution for it if you want a special one for a month job etc just add the needed output format to date and you are ready to run...

        Hope that for first solves your question

        golodhrim Martin Scholz added a comment -

        as there is no big need for discussion of users as I saw, I close that bug too, cause the guide is online and I don't want to let the bug stay to long open...


          People

          • Assignee:
            golodhrim Martin Scholz
            Reporter:
            golodhrim Martin Scholz
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: