Uploaded image for project: 'Funtoo Linux'
  1. Funtoo Linux
  2. FL-310

emerald 0:8:8 fails with /lib/libm.so.6: could not read symbols: Invalid operation

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Environment:

      ~x86

      Description

      This bug is essentially similar to bug reported on FL-295. Upon further research I am beginning to understand the problem. I think it is due to poorly written code that assumes links and those linking mechanisms have been changed a couple of years ago. It is discussed at http://fedoraproject.org/wiki/UnderstandingDSOLinkChange
      and other places. Over my head, but I got the idea enough. In this case I added (temporarily) LDFLAGS='-Wl,-lm,-ldl' to /etc/portage/make.conf. The -ldl was added after 1st failure run with make.conf modification as I then received a similar error but this time referring to libdl. It then installs without incident. A patch would be a better fix.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                sputnik Mike Johnson
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: