Uploaded image for project: 'Funtoo Linux'
  1. Funtoo Linux
  2. FL-8367

subversion.eclass: dev-vcs/subversion missing USE flag 'http'

Details

    • Bug
    • Status: Ready to Fix
    • Normal
    • Resolution: Unresolved
    • None

    Description

      While writing some personal experimental ebuilds I stumbled upon a bug in subversion.eclass. I wanted to checkout some sources with subversion inside the ebuild with subversion.eclass, but it always failed and told me it was unable to resolve the domain of the given ESVN_REPO_URI. Replacing the domain name with an IP address did not change this behaviour. But doing the svn checkout command manually worked as expected.

      I would suspect all subversion-based ebuilds are affected, although there are not many. To replicate, for example a svn-based ebuild like

      emerge -1 =dev-util/kbuild-9999
      

      will generate the following error

      emerge: there are no ebuilds built with USE flags to satisfy "dev-vcs/subversion[http]".
      !!! One of the following packages is required to complete your request:
      - dev-vcs/subversion-1.14.0-r1::dev-kit (Missing IUSE: http)
      (dependency required by "dev-util/kbuild-9999::dev-kit" [ebuild])
      (dependency required by "=dev-util/kbuild-9999" [argument])
      

      A similiar behaviour has also been reported on the Gentoo bugtracker: https://bugs.gentoo.org/725952

      Replacing the file subversion.eclass in /var/git/meta-repo/kits/core-kit/eclass/ with the Gentoo one (https://gitweb.gentoo.org/repo/gentoo.git/tree/eclass/subversion.eclass) solved the problem for me and everything seems to work fine thereafter.

      It would be great to have this working as some (older) projects hosted on Sourceforge only provide a subversion repo and tracking them with git-svn is not an option for me.

      Can we please apply the update on subversion.eclass from Gentoo to get working subversion-based ebuilds?

      Gentoo changes are here: https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=6c48c67facb649b46f984e8f6201deb7c44d32a6

      Thanks!

      Attachments

        Activity

          People

            Unassigned Unassigned
            eyesee eyesee
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated: