Uploaded image for project: 'Funtoo Linux'
  1. Funtoo Linux
  2. FL-821

New sys-devel/gcc ebuilds are incapable of cross-compiling

Details

    • Bug
    • Status: Closed
    • Normal
    • Resolution: Fixed
    • None
    • None
    • >=sys-devel/gcc-4.6.4-r2

    Description

      All gcc ebuilds starting from gcc-4.6.4-r2 (ones that have been funtooized and not using toolchain.eclass anymore) are totally incapable of crosscompiling. They are both missing --target directive and CTARGET is set to CHOST in pkg_setup(). This either needs to be work-arounded by backporting some parts of toolchain.eclass or guarded by big fat warning when CTARGET != CHOST is detected, that this version just could not cross-compile.

      Older ebuilds, such as 4.6.2-r1 and 4.3.3-r2 have no such problem as they are using toolchain.eclass.

      Attachments

        Issue Links

          Activity

            People

              drobbins drobbins
              iamtakingiteasy iamtakingiteasy
              Votes:
              1 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: