Uploaded image for project: 'Funtoo Linux'
  1. Funtoo Linux
  2. FL-8041

kwayland-5.59.0 build fails with QHash error

Details

    • Bug
    • Status: Closed
    • Normal
    • Resolution: Fixed
    • None
    • None
    • Emerge of kwayland-5.59.0 against qt-5.15.2 fails with similar error although package versions are not the same.
    • Older version of kwayland has no reference to QHash which was added in newer versions of qt.
    • Adding the attached kwayland-5.59.0-qt-5.15.2.patch to local patches enables emerge to complete.

    Description

      kde-frameworks/kwayland-5.59.0 from kde-kit/5.19-release

      Problem is similar to what is described here: https://bugs.gentoo.org/703696

      kde-frameworks/kwayland-5.64.0 w/ Qt 5.14.0: error: field ‘outputs’ has incomplete type ‘QHash<KWayland::Server::OutputInterface*, KWayland::Server::XdgOutputInterface*>’

       

       

      Reference: https://forums.funtoo.org/topic/4913-error-kde-frameworkskwayland-5590/

      Attachments

        Activity

          People

            Unassigned Unassigned
            cardinal cardinal
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: