Uploaded image for project: 'Funtoo Linux'
  1. Funtoo Linux
  2. FL-6963

net-fs/s3ql-2.33 needs fix to work with pycryptodome

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Description

      The ebuild was changed to pull pycryptodome instead of pycrypto, but it doesn't quite work out of the box. The following file needs a change from 'pycrypto' to 'pycryptodome'.

      /usr/lib64/python3.6/site-packages/s3ql-2.33-py3.6.egg-info/requires.txt

      Without the change, the following error occurs when mounting a filesystem:

      pkg_resources.DistributionNotFound: The 'pycrypto' distribution was not found and is required by s3ql

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            dkg dkg
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: