Uploaded image for project: 'Funtoo Linux'
  1. Funtoo Linux
  2. FL-6561

can't install media-libs/libvpx-1.8.0-r1 due to dependency conflict

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Expected Behavior
    • Affects Version/s: None
    • Fix Version/s: None
    • CatPkg:
      media-libs/libvpx
    • Kit/Branch:
      media-kit/1.4-release

      Description

      Due to dependency conflict, I can't update my package media-libs/libvpx

       

      emerge -1va =libvpx-1.8.0-r1 --verbose-conflicts
      
      These are the packages that would be merged, in order:
      
      Calculating dependencies... done!
      [ebuild     U #] media-libs/libvpx-1.8.0-r1:0/6::media-kit [1.7.0:0/5::media-kit] USE="highbitdepth postproc svc threads -abi_riscv_lp64 -abi_riscv_lp64d -doc -static-libs -test" CPU_FLAGS_X86="(-avx%*) (-avx2%*) (-mmx%*) (-sse%*) (-sse2%*) (-sse3%*) (-sse4_1%*) (-ssse3%*)" 0 KiB
      
      Total: 1 package (1 upgrade), Size of downloads: 0 KiB
      
      !!! Multiple package instances within a single package slot have been pulled
      !!! into the dependency graph, resulting in a slot conflict:
      
      media-libs/libvpx:0
      
        (media-libs/libvpx-1.8.0-r1:0/6::media-kit, ebuild scheduled for merge) pulled in by
          =media-libs/libvpx-1.8.0-r1 (Argument)
          >=media-libs/libvpx-1.5:0/6=[svc] required by (dev-qt/qtwebengine-5.12.3:5/5.12::core-ui-kit, installed)
                                 ^^^^^                                                                                                                
      
        (media-libs/libvpx-1.7.0:0/5::media-kit, installed) pulled in by
          media-libs/libvpx:0/5= required by (media-video/vlc-3.0.7.1:0/5-9::media-kit, installed)
                           ^^^^^                                                                                                      
          >=media-libs/libvpx-1.3.0:0/5=[-mgorny(-)] required by (media-plugins/gst-plugins-vpx-1.14.4:1.0/1.0::media-kit, installed)
                                   ^^^^^                                                                                                                                 
          >=media-libs/libvpx-1.4.0:0/5=[-mgorny(-)] required by (media-video/ffmpeg-3.4.6:0/55.57.57::media-kit, installed)
      

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            quantum quantum
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: