Uploaded image for project: 'Funtoo Linux'
  1. Funtoo Linux
  2. FL-6355

New nvidia-drivers available for testing

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • CatPkg:
      /github.com/TemptorSent/overlay-nvidia-kit nvidia-kit
    • Kit/Branch:
      1.3

      Description

      NOTE: I'm going to use this issue to track the merging of the new nvidia-drivers stuff from TemptorSent into Funtoo.

       

      >>> Installing (3 of 3) x11-drivers/nvidia-kernel-modules-418.56::nvidia-kit

      • Updating module dependencies for 4.9.161_p1-debian-sources-lts ... [ ok ]
      • Adding module to moduledb.
      • Messages for package x11-drivers/nvidia-drivers-418.56-r2:
      • You must be in the video group to use the NVIDIA device
      • For more info, read the docs at
      • https://www.gentoo.org/doc/en/nvidia-guide.xml#doc_chap3_sect6
      • This ebuild installs a kernel module and X driver. Both must
      • match explicitly in their version. This means, if you restart
      • X, you must modprobe -r nvidia before starting it back up
      • To use the NVIDIA GLX, run "eselect opengl set nvidia"
      • To use the NVIDIA CUDA/OpenCL, run "eselect opencl set nvidia"
      • NVIDIA has requested that any bug reports submitted have the
      • output of nvidia-bug-report.sh included.
      • (Note: Above message is only printed the first time package is
      • installed. Please look at /usr/share/doc/nvidia-drivers-418.56-r2/README.gentoo*
      • for future reference)
        >>> Auto-cleaning packages...

      >>> No outdated packages were found on your system.

      • GNU info directory index is up-to-date.

      !!! existing preserved libs:
      >>> package: media-libs/mesa-18.2.8

      • - /usr/lib64/libgbm.so.1
      • - /usr/lib64/libgbm.so.1.0.0
      • used by /usr/bin/Xwayland (x11-base/xorg-server-1.20.1-r1)
      • used by /usr/lib64/libcogl.so.20.4.2 (media-libs/cogl-1.22.2)
      • used by /usr/lib64/libgstgl-1.0.so.0.1404.0 (media-libs/gst-plugins-base-1.14.4-r1)
      • used by 2 other files
        Use emerge @preserved-rebuild to rebuild packages using these libraries
        funtoomex /var/git/overlay # emerge @preserved-rebuild
        Calculating dependencies... done!
        [ebuild N ] media-libs/mesa-18.2.8 USE="classic dri3 egl gallium gbm gles2 llvm opencl vdpau wayland xa -d3d9 -debug -gles1 -lm_sensors -osmesa -pax_kernel -pic (-selinux) -test -unwind -vaapi -valgrind -vulkan -xvmc" VIDEO_CARDS="(-freedreno) -i915 -i965 (-imx) -intel -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi (-vc4) -virgl (-vivante) -vmware"
        [ebuild R ] media-libs/gst-plugins-base-1.14.4-r1
        [ebuild R ] media-libs/cogl-1.22.2
        [ebuild R ] x11-base/xorg-server-1.20.1-r1
        [ebuild R ] x11-wm/mutter-3.30.2
        [blocks B ] media-libs/mesa[-libglvnd(-)] ("media-libs/mesa[-libglvnd(-)]" is blocking media-libs/libglvnd-1.0.0.20180524)
      • Error: The above package list contains packages which cannot be
      • installed at the same time on the same system.

      (media-libs/libglvnd-1.0.0.20180524:0/0::media-kit, installed) pulled in by
      >=media-libs/libglvnd-1.0.0.20180424 required by (x11-drivers/nvidia-drivers-418.56-r2:0/418::nvidia-kit, installed)

      (media-libs/mesa-18.2.8:0/0::core-gl-kit, ebuild scheduled for merge) pulled in by
      media-libs/mesa required by (gnome-base/gnome-shell-3.30.2:0/0::gnome-kit, installed)
      media-libs/mesa required by (media-sound/spotify-1.1.0:0/0::media-kit, installed)
      >=media-libs/mesa-9.1.6[opencl,-mgorny(-)] required by (virtual/opencl-0-r5:0/0::xorg-kit, installed)
      media-libs/mesa[egl] required by (dev-qt/qtgui-5.11.2-r1:5/5.11::core-ui-kit, installed)
      >=media-libs/mesa-9.1.6[-mgorny(-),egl,gles2,wayland] required by (media-libs/libsdl2-2.0.9:0/0::media-kit, installed)
      media-libs/mesa[gbm] required by (media-libs/cogl-1.22.2:1.0/20::gnome-kit, ebuild scheduled for merge)
      >=media-libs/mesa-9.0[egl?,gbm?,gles2?,wayland?,-mgorny(-)] (>=media-libs/mesa-9.0[egl,wayland,-mgorny(-)]) required by (media-libs/gst-plugins-base-1.14.4-r1:1.0/1.0::media-kit, ebuild scheduled for merge)
      media-libs/mesa[gles2] required by (media-libs/cogl-1.22.2:1.0/20::gnome-kit, ebuild scheduled for merge)
      media-libs/mesa[egl?,gles2?] (media-libs/mesa[egl]) required by (x11-apps/mesa-progs-8.3.0:0/0::xorg-kit, installed)
      >=media-libs/mesa-9.1.6[egl,-mgorny(-)] required by (x11-libs/cairo-1.16.0-r1:0/0::gnome-kit, installed)
      >=media-libs/mesa-18[egl,gbm] required by (x11-base/xorg-server-1.20.1-r1:0/1.20.1::xorg-kit, ebuild scheduled for merge)
      media-libs/mesa[egl] required by (app-office/libreoffice-6.1.3.2:0/0::desktop-kit, installed)
      media-libs/mesa[egl,gles2] required by (gnome-base/gnome-session-3.30.1:0/0::gnome-kit, installed)
      >=media-libs/mesa-9.1.6[-mgorny(-),gles2] required by (media-libs/libsdl2-2.0.9:0/0::media-kit, installed)
      >=media-libs/mesa-18 required by (x11-base/xorg-server-1.20.1-r1:0/1.20.1::xorg-kit, ebuild scheduled for merge)
      media-libs/mesa[egl,-mgorny(-)] required by (media-libs/libepoxy-1.5.2:0/0::xorg-kit, installed)
      media-libs/mesa[egl,wayland] required by (media-libs/cogl-1.22.2:1.0/20::gnome-kit, ebuild scheduled for merge)
      >=media-libs/mesa-17.2.0[egl] required by (x11-wm/mutter-3.30.2:0/0::gnome-kit, ebuild scheduled for merge)
      media-libs/mesa required by (media-video/movit-1.6.2:0/0::media-kit, installed)
      media-libs/mesa[egl] required by (net-libs/webkit-gtk-2.22.2:4/37::gnome-kit, installed)
      >=media-libs/mesa-10.3[egl,gbm,wayland] required by (x11-wm/mutter-3.30.2:0/0::gnome-kit, ebuild scheduled for merge)
      media-libs/mesa[wayland] required by (x11-libs/gtk+-3.24.1:3/3::gnome-kit, installed)
      >=media-libs/mesa-9.1.6[-mgorny(-)] required by (virtual/opengl-7.0-r2:0/0::xorg-kit, installed)

      For more information about Blocked Packages, please refer to the following
      section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

      https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

      funtoomex /var/git/overlay #

        Attachments

          Activity

            People

            Assignee:
            drobbins drobbins
            Reporter:
            messana Riccardo Messana
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: