Uploaded image for project: 'Funtoo Linux'
  1. Funtoo Linux
  2. FL-5036

x11-libs/libva-1.8.3 with USE utils there is not media-video/libva-utils compatible

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
    • Environment:
    • CatPkg:
      x11-libs/libva
    • Kit/Branch:
      xorg-kit/1.19-prime

      Description

      I did 'emerge -pv1 libva' and I have:

      These are the packages that would be merged, in order: 
      
      Calculating dependencies... done! 
      [ebuild   R    ] x11-libs/libva-1.8.3::xorg-kit  USE="X drm egl opengl utils* vdpau -wayland" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="nvidia -fglrx -i965 -intel -nouveau
      " 0 KiB 
      [ebuild     U *] x11-libs/libva-9999::xorg-kit [1.8.3::xorg-kit] USE="X drm egl opengl utils* vdpau -wayland" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="nvidia -fglrx -i965
      -intel -nouveau" 0 KiB 
      [ebuild  N     ] media-video/libva-utils-2.0.0-r1::media-kit  USE="X drm {-test} -wayland" 1,010 KiB 
      
      Total: 3 packages (1 upgrade, 1 new, 1 reinstall), Size of downloads: 1,010 KiB 
      
      Oops! Conflicts have been encountered:                                                                                                                                  
                                                                                                                                                                             
      >>> media-video/libva-utils-2.0.0-r1:0/0::media-kit, ebuild scheduled for merge, wants >=x11-libs/libva-2.0.0:=[drm?,wayland?,X?]                                       
      
      My candidates are: 
                                                                                                                                                                             
      >>> x11-libs/libva-1.8.3:0/0::xorg-kit, ebuild scheduled for merge has SLOT 0/0                                                                                         
      >>> x11-libs/libva-9999:0/0::xorg-kit, ebuild scheduled for merge has SLOT 0/0 
      
      
      
      We hope this informational output has been useful in identifying the 
      problem. We are continually working to reduce conflicts. Do not 
      hesitate to report a bug at https://bugs.funtoo.org. Thank you! :) 
      
      
      The following keyword changes are necessary to proceed: 
      (see "package.accept_keywords" in the portage(5) man page for more details) 
      # required by media-plugins/gst-plugins-vaapi-1.12.4::media-kit 
      # required by media-plugins/gst-plugins-meta-1.12.3::media-kit[vaapi] 
      # required by media-video/subtitleeditor-0.54.0::media-kit 
      # required by @selected 
      # required by @world (argument) 
      =x11-libs/libva-9999 ** 
      
      NOTE: The --autounmask-keep-masks option will prevent emerge 
           from creating package.unmask or ** keyword changes. 
      
      * In order to avoid wasting time, backtracking has terminated early 
      * due to the above autounmask change(s). The --autounmask-backtrack=y 
      * option can be used to force further backtracking, but there is no 
      * guarantee that it will produce a solution.
      
      
      

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            cafaia cafaia [X] (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: