Uploaded image for project: 'Funtoo Linux'
  1. Funtoo Linux
  2. FL-4445

MyPaint will not build due to conflicts

Details

    Description

      MyPaint fails due to conflicts

      Calculating dependencies... done!
      [ebuild  N     ] dev-python/namespace-google-1::python-kit  PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_5 -python3_6" 0 KiB
      [ebuild  N     ] dev-python/protobuf-python-3.4.1:0/14::python-kit  PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6" 0 KiB
      [ebuild     UD ] dev-libs/protobuf-3.3.0:0/13::dev-kit [3.4.1:0/14::dev-kit] USE="python%* zlib -emacs -examples -java% -static-libs {-test}" ABI_X
      86="32 (64) (-x32)" PYTHON_TARGETS="python2_7%* python3_4%* -python3_5% -python3_6%" 4,235 KiB
      [ebuild  N     ] media-gfx/mypaint-1.2.1::media-kit  LINGUAS="en_GB -cs -de -en_CA -es -fr -hu -id -it -ja -ko -nb -nn_NO -pl -pt_BR -ro -ru -sl -s
      v -uk -zh_CN -zh_TW" PYTHON_TARGETS="python2_7" 37,009 KiB

      Total: 4 packages (1 downgrade, 3 new), Size of downloads: 41,244 KiB

      Oops! Conflicts have been encountered:

      >>> media-gfx/mypaint-1.2.1:0/0::media-kit, ebuild scheduled for merge, wants dev-libs/protobuf[python]
      >>> media-sound/clementine-1.3.1-r5:0/0::media-kit, installed, wants dev-libs/protobuf:0/14=
      >>> dev-qt/qtwebengine-5.9.2:5/5.9::kde-kit, installed, wants dev-libs/protobuf:0/14=
      >>> dev-python/protobuf-python-3.4.1:0/14::python-kit, ebuild scheduled for merge, wants ~dev-libs/protobuf-3.4.1

      My candidates are:

      >>> dev-libs/protobuf-3.3.0:0/13::dev-kit, ebuild scheduled for merge has SLOT 0/13
      >>> dev-libs/protobuf-3.4.1:0/14::dev-kit, installed has SLOT 0/14

      Attachments

        Activity

          People

            Unassigned Unassigned
            tefrem34 tefrem34 [X] (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: