Uploaded image for project: 'Funtoo Linux'
  1. Funtoo Linux
  2. FL-4241

too many errors using the new "portage" ....

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Description

      I hope these problems can only be "temporary"; otherwise the idea of kits .... will not be imho) a good idea but a "supplative" comic.
      Kits are born to bring "enterprise" Funtoo; but in my "journey" I encounter many errors and inconsistencies: '(
      With that I can not absolutely be offensive ... on the contrary.
      I'm a little puzzled: |
      Forgive me ... please '

       

       

      Database contains 19629 packages in 164 categories
      ci74771ht ~ # emerge -1 boost
      Calculating dependencies... done!
      [ebuild     U  ] dev-util/boost-build-1.63.0 [1.62.0-r1]
      [ebuild     U  ] dev-libs/boost-1.63.0 [1.62.0-r1] PYTHON_TARGETS="-python3_6%"  

      !!! Multiple package instances within a single package slot have been pulled
      !!! into the dependency graph, resulting in a slot conflict:

      dev-libs/boost:0

       (dev-libs/boost-1.63.0:0/1.63.0::core-kit, ebuild scheduled for merge) pulled in by
         dev-libs/boost (Argument)

       (dev-libs/boost-1.62.0-r1:0/1.62.0::core-kit, installed) pulled in by
         dev-libs/boost:0/1.62.0= required by (dev-util/mdds-1.2.3:1/1.2::dev-kit, installed)
                       ^^^^^^^^^^                                                                           
                           
         (and 10 more with the same problem)

      NOTE: Use the '--verbose-conflicts' option to display parents omitted above

      It may be possible to solve this problem by using package.mask to
      prevent one of those packages from being selected. However, it is also
      possible that conflicting dependencies exist such that they are
      impossible to satisfy simultaneously.  If such a conflict exists in
      the dependencies of two different packages, then those packages can
      not be installed simultaneously. You may want to try a larger value of
      the --backtrack option, such as --backtrack=30, in order to see if
      that will solve this conflict automatically.

      For more information, see MASKED PACKAGES section in the emerge man
      page or refer to the Gentoo Handbook.

        Attachments

          Activity

            People

            Assignee:
            drobbins drobbins
            Reporter:
            sandro sandro
            Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: