Funtoo Linux
  1. Funtoo Linux
  2. FL-383

x11-libs/xvba-video-0.8.0-r[12] fails to build with python 3

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Normal Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Description

      x11-libs/xvba-video-0.8.0-r1 and -r2 fail to build with Python 3 eselected.

      Steps to reproduce:

      • eselect python set python3.2
      • emerge xvba-video

      xvba-video-0.8.0 compiles fine with any python version selected.

      1. build.log
        12 kB
        Jean-Francis Roy
      2. xvba-video-0.8.0-python3.patch
        1 kB
        Jean-Francis Roy

        Activity

        Jean-Francis Roy added a comment -

        The python script that fails with python 3 is fairly simple, I will provide a patch.

        Jean-Francis Roy added a comment -

        Attached Python3 conversion patch.

        Jean-Francis Roy added a comment -

        I committed x11-libs/xvba-video-0.8.0-r3 with attached patch, masked for testing. It will appear in the tree on next sync.

        Steps to confirm resolution:

        1. Wait for =x11-libs/xvba-video-0.8.0-r3 to appear in the tree
        2. Unmask =x11-libs/xvba-video-0.8.0-r3
        3. Ensure python3 is eselected: eselect python set python3.2
        4. emerge --oneshot =xvba-video-0.8.0-r3

        Waiting for confirmation before closing this bug.

        Jean-Francis Roy added a comment -

        For the record: There is a related Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=453036. Sent the patch upstream.

        Kevin Parent added a comment -

        Unmasked xvba-video-0.8.0-r3. eselected python3.2 as default python. Emerged xvba-video-0.8.0-r3 sucessfully. Looks like your fix did the trick.

        Is it safe to leave python3.2 as the default now? I only ask because I just started this new system and it seems that the new default is python3.2.

        Daniel Robbins added a comment -

        Yes, it is safe to have your default python as 3.2 now.


          People

          • Assignee:
            Jean-Francis Roy
            Reporter:
            Jean-Francis Roy
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development

                Structure Helper Panel