Uploaded image for project: 'Funtoo Linux'
  1. Funtoo Linux
  2. FL-2603

'emerge gpa' should notify user of pinentry requirements

Details

    • Improvement
    • Status: Closed
    • Normal
    • Resolution: Incomplete
    • None
    • current generic_64

    Description

      'emerge gpa' produced a somewhat-working GPA installation, but when signing or decrypting, it would not prompt for a passphrase. Instead, it would immediately say "Wrong passphrase!"

      I solved this by adding the gtk flag to the pinentry program, adding this line to /etc/portage/package.use:

      >=app-crypt/pinentry-0.9.4-r1 gtk
      

      and then ran:

      eselect pinentry set pinentry-gtk-2
      

      It took me quite a while to figure this out. It would be nice if you could add some kind of clue to the end of the 'emerge gpa' output. Even just a note like "be sure pinentry supports your GUI environment" would help put the sysadmin on the right track.

      Attachments

        Activity

          People

            Unassigned Unassigned
            hick518 hick518
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: