Uploaded image for project: 'Funtoo Linux'
  1. Funtoo Linux
  2. FL-1497

Compilation failed app-text/rarian-0.8.1-r2

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
    • Environment:

      LINGUAS="fr"

      Description

      I have a compilation error when I executed the following : emerge -u app-text/rarian.

      If I set LINGUAS="en", it compiles fine.

      If LINGUAS="fr", I have the following error :

      >>> Failed to emerge app-text/rarian-0.8.1-r2, Log file:
      >>>  '/var/tmp/portage/app-text/rarian-0.8.1-r2/temp/build.log'
       * Messages for package app-text/rarian-0.8.1-r2:
       * ERROR: app-text/rarian-0.8.1-r2 failed (compile phase):
       *   emake failed
       *
       * If you need support, post the output of `emerge --info '=app-text/rarian-0.8.1-r2'`,
       * the complete build log and the output of `emerge -pqv '=app-text/rarian-0.8.1-r2'`.
       * The complete build log is located at '/var/tmp/portage/app-text/rarian-0.8.1-r2/temp/build.log'.
       * The ebuild environment file is located at '/var/tmp/portage/app-text/rarian-0.8.1-r2/temp/environment'.
       * Working directory: '/var/tmp/portage/app-text/rarian-0.8.1-r2/work/rarian-0.8.1'
       * S: '/var/tmp/portage/app-text/rarian-0.8.1-r2/work/rarian-0.8.1'
      

        Attachments

          Issue Links

            Activity

            oleg Oleg Vinichenko added a comment -

            please, attach output of `locale`.

            oleg Oleg Vinichenko added a comment -

            I guess the cause of a porblem is that missing support for locales. By default Funtoo stages comes with en_US.UTF-8 support only. To enable custom locales, user need to set corresponding locale in /etc/locale.gen, then run locale-gen.

            drieu damien Rieu added a comment - - edited

            Here is my make.conf :

            CFLAGS="-O2 -march=i686 -mtune=generic -pipe"
            CXXFLAGS="-O2 -march=i686 -mtune=generic -pipe"
            
            MAKEOPTS="-j4"
            
            LINGUAS="fr"
            #LINGUAS="en"
            LANGUAGE="en_US fr_FR"
            

            Here is the output of locale command :

            locale
            locale: Cannot set LC_CTYPE to default locale: No such file or directory
            locale: Cannot set LC_MESSAGES to default locale: No such file or directory
            locale: Cannot set LC_ALL to default locale: No such file or directory
            LANG=en_US.UTF-8
            LC_CTYPE="en_US.UTF-8"
            LC_NUMERIC="en_US.UTF-8"
            LC_TIME="en_US.UTF-8"
            LC_COLLATE=POSIX
            LC_MONETARY="en_US.UTF-8"
            LC_MESSAGES="en_US.UTF-8"
            LC_PAPER="en_US.UTF-8"
            LC_NAME="en_US.UTF-8"
            LC_ADDRESS="en_US.UTF-8"
            LC_TELEPHONE="en_US.UTF-8"
            LC_MEASUREMENT="en_US.UTF-8"
            LC_IDENTIFICATION="en_US.UTF-8"
            LC_ALL=
            
            ocale-gen 
             * Generating 2 locales (this might take a while) with 1 jobs
             *  (1/2) Generating fr_FR.ISO-8859-1 ... [ ok ]
             *  (2/2) Generating fr_FR.ISO-8859-15@euro ... [ ok ]
             * Generation complete
            

            Then, emerge app-text/rarian failed

            However, If I change to EN my portage.conf then after a full world update, all compile fine.

            oleg Oleg Vinichenko added a comment -

            it looks like changing french locale to Unicode one, should fix the issue. Independent test with LC_ALL=fr_FR.UTF_8 , LANG=fr_FR.UTF-8 shows no compile issues.

            dantrell Dantrell B. added a comment -

            The actual issue here is your LANGUAGE definition. First of all, it probably shouldn't be set in make.conf but wherever it is set, it should contain a colon-separated priority list of locales. Basically, this will build:

            LINGUAS="en"
            LANGUAGE="en_US:fr_FR"
            

            You can follow up on FL-1140 for more information regarding localization.


              People

              • Assignee:
                dantrell Dantrell B.
                Reporter:
                drieu damien Rieu
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: