Uploaded image for project: 'Funtoo Linux'
  1. Funtoo Linux
  2. FL-1429

git pull error in /usr/portage [...] git did not send all necessary objects

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Description

      Today I've tried to run eix-sync and it failed with error:

      >>> Starting git pull...
      remote: Counting objects: 644, done.
      remote: Compressing objects: 100% (539/539), done.
      remote: Total 644 (delta 145), reused 255 (delta 105)
      Receiving objects: 100% (644/644), 1.49 MiB | 667.00 KiB/s, done.
      Resolving deltas: 100% (145/145), done.
      fatal: missing blob object '7803cdb58252cab6a068d1dd257f30f33b9d7ad9'
      error: git://github.com/funtoo/ports-2012.git did not send all necessary objects
      
      !!! git pull error in /usr/portage.
      

      I've tried to fix/check git repo in /usr/portage with different methods suggested @ stackoverflow, but nothing helped.

      Also I ran this command git rev-list --verify-objects --stdin --not --all and got output:
      fb76f3f0dd22cf1eba2b28b1f1c50c688a3fa251 app-i18n
      c066cae9ab8ca87ac89ac628147f735171cf0925 app-i18n/libguess
      2dcac4bff5cf74dbcaa6f30c6f0e0ec3fe3c9a83 app-i18n/libguess/Manifest
      69a63bc47b0cc919644a8c9dcf80ffc6271c547b app-i18n/libguess/libguess-1.2.ebuild
      fatal: missing blob object '7803cdb58252cab6a068d1dd257f30f33b9d7ad9'
      

      ATTN: To resolve, start with this comment.

        Attachments

          Activity

            People

            • Assignee:
              dantrell dantrell [X] (Inactive)
              Reporter:
              m03geek Alexander Kureniov
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: