Uploaded image for project: 'Funtoo Linux'
  1. Funtoo Linux
  2. FL-1274

PYTHON_ABIS does not match installed python: 2.7, 3.3, 3.4

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Description

      Somehow, python-3.4 snuck into Funtoo Linux, and yet we only have PYTHON_ABIS set to 2.7 and 3.3. This means we have an extra version of python installed that isn't really needed, and python modules will only be installed for 2.7 and 3.3, which is not good.

      Suggestion: move PYTHON_ABIS to 2.7 3.4, mask dev-lang/python properly so we don't get 3.5+ by accident. Or, mask 3.4 to resolve this.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              drobbins drobbins
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: