Uploaded image for project: 'Funtoo Linux'
  1. Funtoo Linux
  2. FL-1171

revdep-rebuild fails to find library files after update to app-portage/gentoolkit-0.3.0.9-r1000

Details

    • Bug
    • Status: Closed
    • Normal
    • Resolution: Incomplete
    • None
    • None
    • None
    • ARM, ~x86 and possibly amd64

    Description

      After updating gentoolkit, I got numerous revdep-rebuild errors on 2 of my machines, please see https://bugs.gentoo.org/show_bug.cgi?id=504654#
      After discussion with the gentoo devs it was obvious the problem was local. On those 2 machines there is no reference on the LDPATH to /usr/lib, and all of the libraries not found were located there. On the 3rd machine there is an 05multilib file in /etc/env.d which contains LDPATH=/usr/lib, sparing it from the same problems. It is the only reference on that machine.
      I have solved the problem temporarily by adding LDPATH=/usr/lib in the /etc/env.d/99local file on both machines, and now run the much more critical gentoolkit-9999 (excellent, btw) with success.
      I confess to ignorance regarding that linker stuff, but I have never tinkered in any way with it, so I am lost in understanding why these files are not included by default.

      Attachments

        Activity

          People

            arfrever Arfrever Frehtes Taifersar Arahesis
            sputnik sputnik
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: