Funtoo Linux
  1. Funtoo Linux
  2. FL-1130

GNOME 3.6 display issues with ati-drivers and nvidia

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Normal Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None

      Description

      The current build of GNOME 3.6 has a display issue with greater than (but not including) ati-drivers-13.6_beta and current nvidia-drivers.

      The display issue appears to be GNOME-specific – a GNOME bug – and results in windows not refreshing properly, until they are dragged.

      1. cogl-1.12.2-glBlitFramebuffer.patch
        1 kB
        Kevin Parent
      2. cogl-1.12.2-r1.ebuild
        3 kB
        Kevin Parent

        Activity

        Hide
        Daniel Robbins added a comment -

        I've unmasked linux-3.13-based kernels as well as ati-drivers-13.12.

        Show
        Daniel Robbins added a comment - I've unmasked linux-3.13-based kernels as well as ati-drivers-13.12.
        Hide
        Kevin Parent added a comment - - edited

        Glad to hear it works with ati-drivers as well. Now we can have modern graphics hardware again! Can you test the latest beta ati-drivers? I thinks it's up to 14.2 or 14.3.

        Show
        Kevin Parent added a comment - - edited Glad to hear it works with ati-drivers as well. Now we can have modern graphics hardware again! Can you test the latest beta ati-drivers? I thinks it's up to 14.2 or 14.3.
        Hide
        Daniel Robbins added a comment -

        Please open another bug for ati-drivers-14.3_beta1.

        Show
        Daniel Robbins added a comment - Please open another bug for ati-drivers-14.3_beta1.
        Hide
        Kevin Parent added a comment -

        On a second machine I've synced and updated to cogl-1.12.2-r2. This machine has a nVidia GT430 and ck-sources kernel 3.10.17 and was running nvidia-drivers-319.49. Updated to latest nvidia-drivers-334-19-r1. Video is smooth at butter! Works perfectly!

        Show
        Kevin Parent added a comment - On a second machine I've synced and updated to cogl-1.12.2-r2. This machine has a nVidia GT430 and ck-sources kernel 3.10.17 and was running nvidia-drivers-319.49. Updated to latest nvidia-drivers-334-19-r1. Video is smooth at butter! Works perfectly!
        Hide
        three sixes almighty added a comment -

        3.13.x kernels work fine with my 9600 gt system, still seizing on the 6000 go series ala hp dv9000. im voting for unmasking as the dv9000 is e-garbage. 9600gt is funtoo, dv9000 is gentoo. just chiming in to reassure you you're making the right choice.

        Show
        three sixes almighty added a comment - 3.13.x kernels work fine with my 9600 gt system, still seizing on the 6000 go series ala hp dv9000. im voting for unmasking as the dv9000 is e-garbage. 9600gt is funtoo, dv9000 is gentoo. just chiming in to reassure you you're making the right choice.

          People

          • Assignee:
            Unassigned
            Reporter:
            Daniel Robbins
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development

                Structure Helper Panel